Apollo Accelerators

Apollo Accelerators Discussion Forum

Search found 1 match

[ Search found 1 match ] 
Author Message
Post subject: Backward Compatibility Vampire V4 Posted: Sat 11 Nov 2017 12:20

Replies: 2
Views: 1277

I'm really tempted to buy the upcoming Standalone Vampire V4. Currently I own a Mist board. Unfortunately this is not compatible with more highend games and Demos. I'd really like to run those highend TBL and Ghostown Demos. Also I think the board would even be powerful enough for a lot of my evergd...
Display: Sort by: Direction:
Go to advanced search [ Search found 1 match ] 

Jump to: 

» The team | Delete all board cookies | All times are UTC+01:00