Apollo Accelerators

Apollo Accelerators Discussion Forum
» » » »
[Locked] [*]  Page 1 of 1  [ 3 posts ]
Author Message
Sinphaltimus
Post subject: [SOLVED] Need help with Fat32 internal SD card Posted: Fri 21 Jul 2017 17:36
Offline
Posts: 29
Joined: Tue 11 Jul 2017 16:15
I have a 32GB CF-Card with the ApolloOS image applied to it and I'm using that as my main system drive. I want to utilize a 16GB SD card on the internal SD slot of the vampire A500+ to transfer files to and from the Amiga and my PC. So removable FAT32 storage.

I already formatted it as FAT32 on my PC. ApolloOS doesn't see it.

SDDiag sees it just find.
HDToolBox sees it just fine.

When I formatted it on my PC I called it SD1 - I'll explain why later.

I also created a mountlist in DEVS:DOSDrivers called SD1 and here is how it is setup:

FileSystem = l:fat95
Unit = 0
Flags = 0
LowCyl = 0
HighCyl = 0
Surfaces = 1
BlocksPerTrack = 1
BlockSize = 512
Buffers = 20
BufMemType = 1
BootPri = 0
Stacksize = 4096
Priority = 5
GlobVec = -1
DosType = 0x46415401
Device = sagasd.device

SOURCE = http://www.apollo-core.com/knowledge.ph ... 1&z=DJsufn

The missing variable for me is in HDToolBox. I can remove filesystems and add fat95 no problem, but in the create partition screen when you have to choose the file system from the settings (right above the add new and change fs buttons) I do not know what to pick. I choose fat/01 but that doesn't allow workbench to popup and NDOS disk for SD1 to format. Nothing actually happens, even after reboot.

I've tried using the default SD0 mountlist that comes with ApolloOS but that is somehow detecting my CF card as SD0:Uninitalized and it wants me for format it showing the capacity as 32GB which is how I know it is seeing my CF card instead of the SD card. so I don't do that I simply cancel the operation and remove SD0 mountlist from DEVS (putting back in STORAGE.

There doesn't seem to be a step by step tutorial on how to format the internal SD card as FAT32 for use with both Amiga and PC via ApolloOS so I'm kind of piecemealing it from different sources and nothing I do works.

Can someone please give me step by step instructions on how best to accomplish this task?

I'm sitting in IRC #Apollo-Team now kind of waiting for anyone who can help to show up. I maybe AFK here and there doing other things, but mostly just sitting here playing with my new turbo charged A500.


Top
[Profile]
Sinphaltimus
Post subject: Re: Need help with Fat32 internal SD card Posted: Fri 21 Jul 2017 19:47
Offline
Posts: 29
Joined: Tue 11 Jul 2017 16:15
#Team-Apollo to the rescue - You can close this topic as solved. I had something wrong in my mountlist.


Top
[Profile]
TuKo
Post subject: Re: Need help with Fat32 internal SD card Posted: Fri 28 Jul 2017 15:08
Offline
Administrateur du site
User avatar
Posts: 88
Joined: Thu 17 Nov 2016 23:29
Location: Switzerland
Contact: YouTube
Thanks for the feedback ! Closing thread.

_________________

A600, V600 V2, A604n+Indi+RTC, CF 32Gb, WiFi
A500+, V500 V2+, Kipper 1MB ChipRAM, CF 32GB, Indivision ECS, ESP8266, Plipbox
A4000D, CS MK2 68060@66MHz 128Mb, Indi MK2cr, CF 16Gb, CV64 4Mb, FastATA MK-VI, Ariadne II


Top
[Profile]
Display: Sort by: Direction:
[Locked]  Page 1 of 1  [ 3 posts ] Return to “Closed topics”

Jump to: 

Who is online

Users browsing this forum: No registered users and 1 guest


» The team | Delete all board cookies | All times are UTC+01:00

cron