Apollo Accelerators

New Vampire 600 v2 Won't Boot (No Logo, No ACT light)
Page 1 of 1
Author:  duane [ Wed 9 May 2018 18:22 ]
Post subject:  New Vampire 600 v2 Won't Boot (No Logo, No ACT light)

TLDR; Booted when I first received the Vampire 600 v2 about a week ago. Froze with artifacts on screen and was VERY hot. Will not boot (Blue power light is on, ACT light flashes once then turns off) with any core (2, 2.7, 2.8, 2.9) flashed. Will boot with no core (erased core).

  1. Got V600v2 last week, installed it (it seated very well right away) and booted into my old MWB3.9 setup.
  2. Let it idle for about 60 minutes and when I returned, there were artifacts on the screen and it was locked up. It would not reboot afterwards. Vampire components extremely hot. (Not sure if that's normal) The Vampire power light was blue, but the red ACT light was not on.
  3. Ordered several USB Blasters (first one was a cheap knockoff that Quartus would not recognize) and tried flashing different cores
  4. During flashing I noticed that my A600 would reboot (which is normal) and start with an error related to makedir (trying to set up the RAM: drive in startup-sequence)
  5. Erased the Core and A600 booted reliably, but stuck at startup error
  6. On a fluke, I tried flashing the GOLD2 JIC (V3_3686_magic_803.jic) and it booted! I set up a clean 3.9 install with the GOLD2 ROM patch (spatch -oRAM:newfile -pARU_Vampire_1_2.pch "DEVS:AmigaOS ROM Update") and earliest SAGA drivers I could get from the wiki (SAGADriver.v0.14.lha) to be as consistent as possible with GOLD2. The blue power light was on and the red ACT light was BRIGHTLY illuminated. I did notice that the Vampire was still running hot.
  7. After a few short sessions in my clean 3.9 install with BB1&2, I tried a longer session to set up a few things (DOpus, tweaking Displaymodes, running VampireSN to register,etc), it froze again and was crazy hot. I powered off, waited for a few minutes and powered back on. Back to square 1: No ACT light, blue power light is on. No IDE/CF Adapter activity. I can erase the core and boot into a broken 3.9 and confirmed the CF Card works in WinUAE. I'm able to successfully flash JIC cores, but none (including GOLD2) will boot.
I registered my Vampire 600 v2 last night when I was finally able to boot and run VampireSN... (there really should be a note in the box that registration is required to avoid the black and white screen limitation) and praying that this is all because the cores I've tried don't have my SN activated yet... but fear my Vampire is just plain faulty.

PS - Yes, I've reseated it over and over again. I really does seat nicely even though it's an A600. I have "SetPatch NOROMUPDATE QUIET" in my startup-sequence, too...

Author:  majsta [ Fri 11 May 2018 17:41 ]
Post subject:  Re: New Vampire 600 v2 Won't Boot (No Logo, No ACT light)

1. Card should be hot, after all when core is compiled it is done with certain temperature profiles with reports how will it behave under that temperature. So 85 degrees Celsius could be considered as normal.
2. ACT LED don't behave same way on different cores. On latest cores could light up only if something bad happened in the system like faulty SDRAM chip etc. Also it could light when FastRam is tested...
3. There are certain questions you need to answer:
a) What is the state of capacitors on that specific A600 motherboard?
b) Did you try different Amiga power supply unit?
c) Did you try to run memory test on chip and on fast with all tests included and paused on error
http://amiga.resource.cx/exp/mbx1230 (MBRTest2)

Author:  duane [ Mon 14 May 2018 03:49 ]
Post subject:  Re: New Vampire 600 v2 Won't Boot (No Logo, No ACT light)


Thank you very much for responding to my message (and email). I appreciate your help very much. I'm sorry for my delayed response. Here are my answers:
  1. Thank you. That makes sense. I'm not familiar with FPGA thermals and performance.
  2. Thanks for the explanation. I thought that the ACT light was bright when the Vampire worked briefly: this was using GOLD2 core.
  3. Here are the answers to your questions:
  1. Recapped a little over 3 years ago. All appear to be healthy (no bulging, no leaks)
  2. I've tried both an A1200 and A500 power supply
  3. I ran the MBRTest2 (thank you for the link) with Vampire installed, but no core. I have an A603 and 2 megs of chip, no fast installed. All tests passed. (photo below)

I installed the latest core (2.9.4) and gave it another shot: still no logo, no boot. For what it's worth, I've tried without the A603 installed, too.

Author:  majsta [ Thu 17 May 2018 12:06 ]
Post subject:  Re: New Vampire 600 v2 Won't Boot (No Logo, No ACT light)

Hi, we will try another approach here.
I will contact you on the mail, we will try to debug card online using teamviewer.

Author:  duane [ Thu 17 May 2018 17:04 ]
Post subject:  Re: New Vampire 600 v2 Won't Boot (No Logo, No ACT light)

Thank you. I will keep an eye open for your email.

Author:  majsta [ Thu 17 May 2018 22:48 ]
Post subject:  Re: New Vampire 600 v2 Won't Boot (No Logo, No ACT light)

Ok info, using team viewer I entered windows machine who was connected over USB blaster to Vampire 600 V2 card mounted on Amiga. This kind of debugging is fun fun fun :) If you think that there is more than 10 000km between us and that you control one machine over another :) Fucking Skynet...
After investigation I can confirm that connection to the motherboard is good. We were able to write to color register and to run test core without addressed FastRam.
Then each SDRAM chip was tested separately. With U8 system booted but with U7 didn't
1. Bad solder job on that chip
2. Damaged in transport, some pins on that chips disconnected or something like that
3. Dead chip

So, like I told you check each pin on that chip U7 with needle and see do they move. As you have proper equipment if that's the case solder it yourself.
If that's not the case card will be replaced.

Author:  duane [ Sat 19 May 2018 05:52 ]
Post subject:  Re: New Vampire 600 v2 Won't Boot (No Logo, No ACT light)

Thanks again for your help. I'm amazed at how well team viewer worked for troubleshooting. I'm incredibly impressed by your dedication to the platform and your product.

Just to wrap up this stage for those following the thread, I've shipped the card back via USPS and shared the tracking number with Majsta.

Page 1 of 1 All times are UTC+02:00
Powered by phpBB® Forum Software © phpBB Limited