Apollo Accelerators

Apollo Accelerators Discussion Forum
» » »
[Post Reply] [*]  Page 1 of 1  [ 7 posts ]
Author Message
Sinphaltimus
Post subject: Incompatible application testing Posted: Sat 22 Jul 2017 13:33
Offline
Posts: 29
Joined: Tue 11 Jul 2017 16:15
Hi,

Testing applications on a full ECS Amiga A500 rev.5 with 1MB Chip ram and Vampire 500v2+ running core GOLDv2 on ApolloOS R42.

UPDATE: I've updated to R43 of Apollo-OS and have indicated which of the following are old or new with the version number as a prefix.

It was suggested I submit this to the team.

R42 - I can't get Fantavision to work in ApolloOS.
***UPDATE*** Fantavision works just fine when booting off the Fantavision disk!

Here is a link to all the different adfs I tested.

https://mega.nz/#!GEdCBQQJ!Qtxr_pSo15aO ... 1RxH1Hfd_U

All PAL versions do not display correctly and I think they freeze the system. It's hard to tell because Mouse pointer is offset by a lot to the left. Only half the screen displays. So I have to reboot to gain control of the system back.

The non PAL version crashes immediately with an error that gets cut off.

I also notice that in all the adf:s/startup-sequences there is a "stack 15000" being executed so I
tried that in cli before running any of the fantavisions and it made no difference.

I have tested the non PAL versions in WinUEA with WB3.1 and it works fine there.

- the issues above happen on the RGB port.


Also My real A500 KS was 40.63 prior to removing it for Vampire install.
I'm using the same v40.63 KS in winUAE.

R42 -Added 07/27/2017 - The RoadShow popup reminder to register interrupts RGB output causing it to stop until the popup is closed. In some instances it will crash whatever program is running in RGB. I purchased RS to get rid of pop-up.

R43 - KNOWN - MiniMon on Goldv2 Crashes - Move it out of WBStartUp
Quote:
EDIT - Testing the following programs preinstalled with ApolloOS and found issues. Testing criteria - just open each program in Programs:Programs/ . See if they open, then close them. I did not try to fix any of the errors. Just quickly ran through each application.
R42 - Voodoo-X
Error 0001
Problem while loading filetypes

R42 - SoundBox
I can't find 'provision.library' (V35+) or installed library is too old.
Please copy this library into LIBS: and start again!

R42 - TurboPrint and related applications
TurboPrefs
Please insert volume TurboPrint in any drive

NoTurbo
ERROR:
TURBOprint is not installed

TurboSpool
Please insert volume TurboPrint in any drive

GraphicsPublisher
Please insert volume TurboPrint in any drive

R42 - TaskPie
Can't initialize SysInfo

R42 - SongPlayer
Please insert volume A-MyFiles in any drive

R42 - KGLoad
Doesn't open at all - blinks screen, gies error beep.

R42 - InstallerGen
InstallerGen
Program failed (error #8000000B)
Wait for disk activity to finish.
Suspend Reboot
******Reboot froze the system - I had to cycle power to recover.

R42 - Imagine 4.0 ******I installed this myself and it works perfectly thus far in RGB mode

R42 - iGame - SPEEDBALL
I chose speedball at random to try one game. Black screen on RGB but it is the active display. With no way to exit or quit, I had to powercycle.

R42 - FMS***Did not test - wasn't prepared to mount adfs been using ADF device before I knew about it. ADF device works.

R42 - Enforcer - didn't seem to do anything.

R42 - EaglePlayer
Please insert volume Work: in any drive

R42 - DeluxeMusic2.0
The font "DMusic/8" could not be found.
Make sure that this font
is installed on your system before running DeluxeMusic2.0.
Quote:
From Programs:Productivity/
R43 - DPaint
Crashes every time with different results.
Just running and starting as is - crashed with error - not enough ram for number of colors.
Reduced number of colors in WB - crashes upon opening.
Crashes upon opening.
I was able to select a 640x480 mode once and just as it was loading into RBG screen my
RTG screen threw a BLUE recoverable error - in the RBG screen I could move the move
around a reduced resolution/colorset of my FTG desktop but not close windows or run DPaint.
Had to reboot. Gave up after that.
R43 - I tried 640x480x256 and it locks up the system.

R42 - WordWorth
Please insert volume Dati in any drive.

R42 - Photogenics - seems to work but not in english.

WORKING - Manually Installed

I installed Octamed Sound Studio and discovered that not only does ti work but when you do the HDD installer it runs via RTG (HDMI)


Last edited by Sinphaltimus on Sat 26 Aug 2017 15:51, edited 12 times in total.

Top
[Profile] [Quote]
Mr-Z
Post subject: Re: Incompatible application testing Posted: Sat 22 Jul 2017 14:01
Offline
User avatar
Posts: 23
Joined: Sun 27 Nov 2016 08:14
I'll test this one on my V600 setup, and A4000 CSPPC (060/60 Mhz) Both OS3.9 BB2 installs.

_________________

Amiga is addictive coz it's fun to use 8-) config: A600 Vampire 2 "Black Edition"


Top
[Profile] [Quote]
Sinphaltimus
Post subject: Re: Incompatible application testing Posted: Sat 22 Jul 2017 15:02
Offline
Posts: 29
Joined: Tue 11 Jul 2017 16:15
I should add that on the vampire - the issues above happen on the RGB port.
Also My real A500 KS was 40.63 prior to removing it for Vampire install.
I'm using the same v40.63 KS in winUAE.


Top
[Profile] [Quote]
Saluda
Post subject: Re: Incompatible application testing Posted: Sun 23 Jul 2017 03:43
Offline
Posts: 12
Joined: Mon 17 Jul 2017 18:31
I get an error with MiniMon when I boot up. Another forum stated MiniMon need Gold 2.5.


Top
[Profile] [Quote]
Sinphaltimus
Post subject: Re: Incompatible application testing Posted: Sun 23 Jul 2017 06:35
Offline
Posts: 29
Joined: Tue 11 Jul 2017 16:15
Saluda wrote: *  Sun 23 Jul 2017 03:43
I get an error with MiniMon when I boot up. Another forum stated MiniMon need Gold 2.5.
You can move the icon for minimon out of WBStartUp to get rid of the error for now.


Last edited by Sinphaltimus on Sun 23 Jul 2017 13:55, edited 1 time in total.

Top
[Profile] [Quote]
Saluda
Post subject: Re: Incompatible application testing Posted: Sun 23 Jul 2017 13:49
Offline
Posts: 12
Joined: Mon 17 Jul 2017 18:31
Thanks, that fix the boot up message. Also went through WBStartUp to clean up the work screen...


Top
[Profile] [Quote]
Sinphaltimus
Post subject: Re: Incompatible application testing Posted: Sun 23 Jul 2017 20:16
Offline
Posts: 29
Joined: Tue 11 Jul 2017 16:15
Finished testing applications in Programs:Productivity/
Added results to Original topic

Also added not about MiniMon.


Top
[Profile] [Quote]
Display: Sort by: Direction:
[Post Reply]  Page 1 of 1  [ 7 posts ] Return to “Vampire 500 V2(+)”

Jump to: 

Who is online

Users browsing this forum: No registered users and 1 guest


» The team | Delete all board cookies | All times are UTC+02:00

cron