Apollo Accelerators

Apollo Accelerators Discussion Forum
» » »
[Post Reply] [*]  Page 1 of 1  [ 3 posts ]
Author Message
Post subject: Faulty Vampire 500 V2 Posted: Sun 4 Feb 2018 11:21
Posts: 2
Joined: Sun 4 Feb 2018 10:46
Have a Vampire 500 v2 that I put in an Amiga 2000, and as it is a pain to connect and disconnect the Vampire I got a cpu socket to make it easier.
I had some issues with the A2k MB, so had taken it out of the case, and that is where I made a very stupid mistake of turning the A2K on with the cpu card the wrong way around.

Now it will not beet with the Vampire card, and all you get in RGB mode is flickering between green and blue screen.
Mostly green.

Was in contact with Majsta, and got an older version of the firmware to re flash the Vampire, as I have a Usb Blaster.
This went well, according to report I got when executing the .bat file.

The behaviour didn't change however so I guess the FPGA itself is ok, but some other component has failed because of this.

Is there anywhere to get this repaired?

If not then any help with trying to figure out what component(s) have failed would be help full.
I have done a bit of soldering, but am not that good at it.
I have no experience in tracking down errors in electrical equipments, so will need help for that.

It's just frustrating to have a Vampire, and then have it collect dust in stead of using it.

[Profile] [Quote]
Post subject: Re: Faulty Vampire 500 V2 Posted: Tue 6 Feb 2018 02:40
User avatar
Posts: 9
Joined: Sat 19 Nov 2016 15:57
Location: Sweden
Contact: Website

Go and ask in the irc-channel: http://webchat.freenode.net/?channels=apollo-team

[Profile] [Quote]
Post subject: Re: Faulty Vampire 500 V2 Posted: Tue 6 Feb 2018 19:22
Posts: 2
Joined: Sun 4 Feb 2018 10:46
Thanks for the link.

I am of course willing to pay for the repair, as it was my own fault, so long as it makes economic sense.

Must be over 15 years since I used IRC last time.
See if I even remember how it works.

[Profile] [Quote]
Display: Sort by: Direction:
[Post Reply]  Page 1 of 1  [ 3 posts ] Return to “Vampire 500 V2(+)”

Jump to: 

Who is online

Users browsing this forum: No registered users and 1 guest

» The team | Delete all board cookies | All times are UTC+01:00