Apollo Accelerators

Apollo Accelerators Discussion Forum

[RESOLVED]Core 2.7 Issues

Post Reply   Page 1 of 1  [ 3 posts ]
Author Message
Post subject: [RESOLVED]Core 2.7 Issues
Posted: Wed 7 Mar 2018 12:41
Posts: 77
Joined: Tue 11 Jul 2017 16:15
On core 2.9 - these issues also no longer exist for me - please close this topic)

Hey team.

Thanks for all your help on IRC especially BIGGUN. Below is my recorded experience for your records and information. I lost power due to a huge storm here in the US and just got back on-line last night. My report is probably old news by now.

As I understand it, if I want to use my SD Card extender I cannot apply any update higher than core 2.7x11. I am fine with that completely. But my issue now is I do not know how to use USB blaster. i couldn't get it to see the Vampire board. I redownloaded all the software last night and am going to try again this coming weekend. Since my understanding is now - usb blaster is the way to go since there are issues with the EXE under Amiga 3.9 (ApolloOS).

The game plan is to apply the new core x11 via USB Blaster, then image to coffin r48.

Then I just have to setup my SDNet and I should be up and running fine. No need to update SAGA driver because it's in Coffin r48 correct?

Anyway, below is what I have typed up before the power outage last Friday.


Well 2.7 didn't really work out for me. I'm back on 2.5 until things are different.
I am willing to go through this process with someone on the Apollo Team, step by step, sheck my startup-sequence first and all that jazz.

This post is long as I documented as much as I can in order to help resolve these issues. I'm OK with waiting for fixes. I'm OK with v2.5 for now. I would like to help in any way I can. so here is my full report on what transpired today.

For the record - IRC user Sinpaltimus here in case anyone wants to review the IRC logs of this experience.

How I upgraded was:
Step1. Downloaded the V500V2(+) exe from
http://wiki.apollo-accelerators.com/dok ... test_cores
Step2. Downloaded SAGA1.0 from here:
Step3: Read the core instructions that came in the LHA file. Changed my startup-sequence as stated and commented out all FEMU stuff.
Step4. Transfered files to Amiga via SD and upgraded the core, no problem.
Step5. Installed SAGA1.0
Step6. Rebooted.

During reboot, Core 2.5 boot screen and vampire audio jingle came, then rebooted. It was stuck in a boot loop doing this 3 - 4 times before...

Step7. Power off Amiga and wait 20 seconds.
Step8. Power on Amiga. Locks up at core 2.7 boot screen. Reboots repeatedly....then freezes on that screen after about the third reboot.
Step9: Got on IRC with Apollo group where BIGGUN helps me get back to booting. It was the changes to the startup sequence causing the inability to boot. So after reverting them, my Amiga booted into my workbench. I tested my SDNet after another user was reporting that it doesn't work. I found that mine didn't work either. So then I tried to mount my SD card and that failed also. So I rebooted.

Step10: Upon rebooting I got a Guru Meditation Error RED. I had to
Step11: Power off and power on again.

Step12: booted into workbench without a mouse pointer.
Step13: Gave up, installed Gold v2.5 core and rebooted.
Step14: Got into workbench, SDNet still not working for internet or SD0 seperately.
Step15: Gave up, reimaged HDD with my original pre2.7 backup.
Step16: Back on corev2.5. Everything works, can reboot without GURU.

Lastly someone mentioned I might want to wait until Coffin r47 is released. Coffin being the new name being used instead of ApolloOS. Which brings a whole other set of headaches requring a reimage where I will loose all my customizations and application I did to ApolloOS r43.

Here are my comments regarding the above summary.

It's too early, there are no straight forward instructions. For instance, the instructions that come with core2.7 upgrade specify startup-sequence changes to the SetPatch line.

The instructions state the following:

>>Here is GOLD2.7 APOLLO Core Update for the Vampire V500 V2(+)

>>Please note the update will reprogram your VAMPIRE. The update will take several >>seconds.

>>The Apollo-Team it not liable for any problem, failures or data loss. Please note >>that you will do the update on your own personal risk. Turning the computer off >>during the update, a power-outage or other failure can render your Vampire non->>operational.

>>Please note that if your turn the Vampire non-functional as described because of >>powerloss - you can get the Vampire operational again by using an external flash >>device. This device is not included and must be purchased separately.

>>*** Note ***
>>Since GOLD2.7 core, you need to set your SetPatch command in Startup-Sequence >>like this :
>>C:SetPatch SKIPROMMODULES "scsi.device,filesystem,exec.library" QUIET

>>Remove also FEMU from your Startup-Sequence if you used it.

This part - caused my crashes:

>>C:SetPatch SKIPROMMODULES "scsi.device,filesystem,exec.library" QUIET

Had to go back and use this:


That was the first issue.

Second Issue:
SDNet not working for internet or SD card access. - NO FIX
I use ARANANET SDNET adaptor with RoadShow. Another user confirmed the following using PlipBox for internet access:

Core 2.5: working, core 2.7-pre4906: working, core 2.7-release: not working

And my mouse pointer dissappeared. But there is a fix for that -

<BigGun> press shift on boot
<BigGun> then amiga will fall back to PAL
<BigGun> then all looks normal
<BigGun> then change the tooltype and reset
_bax_> Sinphaltimus: You don't have to remove the pointer. set SOFTSPRITE=YES in devs:monitors/vampiregfx.info tooltypes will do the trick
14:20 B<_bax_> (s/pointer/driver)

And finally, when rebooting.... GURU Meditation. I could get into WB from a COLD power up but rebooting or resetting resulted in a GURU meditation error.

So I backed out.

There really should be a straight forward set of instructions that take a user through the process step by step for this core2.7.

There should be a set of instructions to accomplish before applying the core.
Like when do we install the new SAGA drivers?
Do we make changes to startup-sequence now?
Do we adjust mouse pointer tooltype now before first reboot?
Should probably be told not to reboot but instead power off.
We have core and saga instructions already and they are pretty easy to follow. But after Core2.7 applied, after startup edited, after saga and mouse pointer fixed - is there anything else. Why doesn't SDNet work?
What version of the core gets installed with the EXE?
Is it x12 when it has been reported SD Extension cables don't work.
I want my SD extension cable, so how do I install a version that is not x12?
I have a USB Blaster and the software and the non x12 jic but my software doesn't detect the vampire board, how do I fix that?

What does a registered vampire user need to do from start to finish in order to have a successful upgrade?

Last edited by Sinphaltimus on Fri 13 Apr 2018 12:38, edited 1 time in total.

Profile Quote
Post subject: Re: Core 2.7 Issues
Posted: Thu 8 Mar 2018 19:33
Posts: 77
Joined: Tue 11 Jul 2017 16:15
Here's a quick update.

Steps I am taking:
1. Boot my A500 to Corev2.5 with ApolloOS r43 and flashed the vampire with core 2.7
2. Powered off Amiga.
3. Imaged hard drive with coffin_r48p_32GB.img.
4. Powered on Amiga.
5. Mounted SD card and it works (with the extension cable)
6. Configured SDNet and RoadShow - Internet is working.
7. Got my max res back and custom wallpaper.
8. I was able to get an SMB share mounted but only using the quick methong in SMBMounter, everything else throws out various arrors.
9. I was able to finally repartition my HDD (se comment to this below for full details)
10. Maintenance mode fixed with help from Tuko. Needed to set DH2: as bootable with priority 1. DH0: priority to 0.

Outstanding Issues or problems encountered:
1. 194x game screen is corrupted and unusable.
2. SMBMounter various errors, cannot open mountlist, cannot mount anything except via quick method.
3. Cannot use ipm help in cli - get error: EXECUTE: Illegal .DEFAULT directive, key "repo" not found object not found

That's where I am at now.

I need to find out how to configure the correct repository so I can update over the internet future releases as mentioned in the readme for coffin

Package Manager

coffin introduces a new package management engine called "IPM" (stands for Idiotic Package Manager). When configured with correct repository, it allows you to download and updates games, applications, videos, etc. from the coffin distribution. It also allows you to upgrade easily your distribution to latest release.

From CLI, type "ipm help" to get a full list of availables commands

I'll come back later with more info on how my journey is working out.

Last edited by Sinphaltimus on Mon 12 Mar 2018 13:37, edited 2 times in total.

Profile Quote
Post subject: How to use bigger than 32GB HDD
Posted: Mon 12 Mar 2018 00:27
Posts: 77
Joined: Tue 11 Jul 2017 16:15
I cloned my Amiga HDD. O=Original to be repartitioned, C = cloned

I plugged in both HDDs to my PC via USB.
I configured winUAE to boot from C (clone) as unit 0.
I configure winUAE to have the O hdd as unit 1
When I start WinUAE I held down the two mouse buttons to go into early startup.

I disabled the partitions on O

Boot to C and the Coffin OS r48 boots up just fine in WinUAE (except for graphics and resolution but who cares. Not why I did it.

I thought it cute when WinUE played the Coffin startup sound though.

Anyway, I changed HDToolbox tooltype to uaehf.device and added drive O wiping out all partitions. I then repartitioned everything to what I want, taking up all 320 GBs (290 +). They are not DH0:,DH1: DH2 but instead WDH0:, WDH1: and WDH2: so they wouldn't conflict with the booted up Cloned drive.

Everything is partitioned as

WDH0: (SYSTEM) 8GBs New PFS3aio final
WDH1: (Programs) 50GBs New PFS3aio final
WDH2: (Restore) 8GBs New PFS3aio
WDH3: (Data) 50GBs New PFS3aio
WDH4: (Backups) 150GBs New PFS3aio experimental for >104GB partitions)
I left the rest of the space at the end of the drive alone and untouched (not partitioned or formatted).

When completed. I booted off the Original repartitioned HDD and got errors, went into HDToolBox and renamed all the Partitions back to DH0: DH1: and DH2:

The system booted fine but I have to restore my Screenmode as it had reverted back to RGB resolutions for some reason.

Now I have a new problem I will add to the list... (This problem has been resolved - see notes in prior posting)

I can't reboot into Maintenance Mode. Can someone help me fix that? If I choose to reboot into maintenance mode none of my partitions come up as bootable and it asks for a 3.1 boot floppy.
(^^^This one issue resolved ^^^)

[ img ]

Profile Quote
Display: Sort by: Direction:
Post Reply   Page 1 of 1  [ 3 posts ]
Return to “Vampire 500 V2(+)”
Jump to: